Jump to content
Sign in to follow this  
ozzyp

Running Hot...too Lean?

Recommended Posts

Timmer,

 

I recently changed out the exhaust on 2011 ZX 10R to a two brothers slip on(eliminating catalytic converter). I also installed a K&N air filter. The map that closest fits what I have is for a two brothers slip on with stock air filter, but now I've been running hotter at moderate speeds. What easy fix, if any, can I do to remedy this? Is there gonna be any new maps to address this? Or will it even help?

 

Thanks,

Ozzy

Share this post


Link to post
Share on other sites

Hey Ozzy,

 

A couple things here...

 

First off, make sure that your K&N filter is not over-oiled. Too much oil can restrict air flow, which can make the engine run hotter and also result in less horsepower. You might try changing your air filter back to the stock filter to see if the overheating goes away. This is a pretty common problem I've seen.

 

Second thing...The map you have installed for a Two Brothers slip-on with stock air filter should get the fueling pretty close, but you can adjust the map further if you would like. You can use the Power Commander Control Center software to make adjustments, which you can download from www.powercommander.com. Connect your Power Commander to your computer using a USB cable. Open the software, and then select the region of the map that you would like to add a little fuel to by clicking and dragging. Then click the "Page Up" button on your keyboard. This will increment the cells that you have highlighted, adding fuel in only that area.

 

Also....if you've got the cash, you can order an Autotune kit. This will allow you to pick the air/fuel ratio that you want and the Power Commander will automatically zero in on this air/fuel ratio as you ride. It will also allow you to check your air/fuel ratio in the Power Commander software.

 

Hope that helps. Let me know if you have anymore questions.

 

Best,

Timmer

Share this post


Link to post
Share on other sites

Take it to a reputable dyno operator and get some c/o readings and see if jetting is an issue. You may be too lean but far too often those downloaded maps are far too rich in my experience. The best way to know and know with certainty is to get c/o readings.

 

I had guhl reflash a 2012 ZX10R and the bike now runs about 6-8* hotter than it did prior to the reflash, which seems pretty common especially with ignition advance advanced.

Share this post


Link to post
Share on other sites

Thanks guys for the advice! I'm fairly limited in my experince here so I always appreciate the help.

 

Ozzy

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...